Backups are failing

Incident Report for Acronis

Update

We are continuing to work on a fix for this issue.
Posted Mar 11, 2026 - 15:56 UTC

Identified

The issue has been identified
Posted Mar 11, 2026 - 15:56 UTC
This incident affects: eu-baas (Europe) (Backup, DR, Security) and us2-baas (United States) (DR).